KIWI'S HOUSE
moeKiwiSAMA
Nov 11, 2018
It takes 13 minutes to read this article.

我也不知道自己在输个啥

创建两个VLAN并将4个口两两分开

有一个交换机,上面四个接口分别为(Fa0/1,Fa0/2,Fa0/3,Fa0/4)

Switch> 用戶模式

Switch>enable

Switch# 特权模式

Switch#configure terminal

Switch(config)# 配置模式

然后咱要创俩VLAN,把它们的编号设置为10和20

Switch(config)#vlan 10 创建一个编号为10的VLAN

Switch(config-vlan)#vlan 20 创建一个编号为20的VLAN

Switch(config-vlan)#exit 返回

然后把它们分别丢进去

Switch(config)#interface f0/1 切到f0/1这个接口

Switch(config-if)#switchport access vlan 10 把f0/1配进vlan10

Switch(config)#interface f0/2 切到f0/2这个接口

Switch(config-if)#switchport access vlan 10 把f0/1配进vlan10

Switch(config)#interface f0/3 切到f0/3这个接口

Switch(config-if)#switchport access vlan 20 把f0/1配进vlan20

Switch(config)#interface f0/4 切到f0/4这个接口

Switch(config-if)#switchport access vlan 20 把f0/1配进vlan20

Switch(config-if)#end 退出

然后咱看看刚刚弄了什么幺蛾子

Switch#show vlan brief

如果在10与20处显示接口已经被分配好了,那就成功了

VLAN Name Status Ports
10 VLAN0010 active Fa0/1, Fa0/2
20 VLAN0020 active Fa0/3, Fa0/4

Access 接入链路

先将4台电脑的网关两两分配 处于192.168.1.x的分配至192.168.1.254 处于192.168.2.x的分配至192.168.2.254

然后在交换机的cli下使用enable和configure terminal进入配置模式

Switch(config)#interface vlan 10 选vlan10

Switch(config-if)#no shutdown 把端口打开

Switch(config-if)#ip address 192.168.1.254 255.255.255.0 设置vlan10网关为192.168.1.254,子网络掩码为255.255.255.0

Switch(config)#interface vlan 20 选vlan20

Switch(config-if)#no shutdown 把端口打开

Switch(config-if)#ip address 192.168.1.254 255.255.255.0 设置vlan20网关为192.168.2.254,子网掩码为255.255.255.0

Switch(config-if)#exit 返回至编辑模式

Switch(config)#ip routing 打开路由功能(356024PS)

Switch(config)#exit 退出编辑模式

到这里差不多就已经好了,咱们可以show一下

Switch#show ip interface brief

按空格可以到最后面 show出下面的样子就可以了

Interface IP-Address OK? Method Status Protocol
VLan10 192.168.1.254 YES manual up up
VLan20 192.168.2.254 YES manual up up

你可以再用4台客户机互相ping一下,ping通应该没什么问题了

修改hostname先通过configure terminal进入配置模式 Switch#hostname moeKiwiSAMA_st 就可以修改hostname

之后CLI中就会出现

moeKiwiSAMA_st(config)#

Trunk 中继链路

现在需要两台交换机:moeKiwiSAMA_st与moekiwisama_nd。

按照上文的步骤,moeKiwiSAMA_st有4个客户机

IP Gateway Vlan 与st连接的Interface
192.168.1.1 192.168.1.254 10 Fa0/1
192.168.1.2 192.168.1.254 10 Fa0/2
192.168.2.1 192.168.2.254 20 Fa0/3
192.168.2.2 192.168.2.254 20 Fa0/4

咱先在st上创建vlan30

moekiwisama_st(config)#vlan 30 创建一个编号为30的VLAN

moekiwisama_st(config)#interface vlan 30 选vlan30

moekiwisama_st(config-if)#no shutdown 把端口打开

moekiwisama_st(config-if)#ip address 192.168.3.254 255.255.255.0 设置vlan30网关为192.168.3.254,子网掩码为255.255.255.0

咱要创建另一个交换机(356024PS),将其命名为moekiwisama_nd,将moekiwisama_nd(F0/1)接上moekiwisama_st(F0/5)。

创建3个客户机,接上moekiwisama_nd交换机

按照上文的步骤,创建3个vlan

TIPS:
moekiwisama_nd(config)#vlan x 创建一个编号为x的VLAN

然后将三个接口分配至3个vlan

TIPS:
moekiwisama_nd(config)#interface f0/x 切到f0/x这个接口
moekiwisama_nd(config-if)#switchport access vlan y 把f0/x配进vlan y

本文的实际环境是这样的,按照实际情况作出修改

IP Gateway Vlan 与st连接的Interface
192.168.1.3 192.168.1.254 10 Fa0/2
192.168.2.3 192.168.2.254 20 Fa0/3
192.168.3.1 192.168.3.254 30 Fa0/4

进入st交换机后台

moekiwisama_st(config)#int f0/5 #选择Fa0/5接口

moekiwisama_st(config-if)#switchport trunk encapsulation dot1q手动设置协议为dot1q

moekiwisama_st(config-if)#switchport mode trunk将f0/5的模式换为trunk

moekiwisama_st(config-if)#switchport trunk allowed vlan 10,20,30使 f0/5 trunk 允许 vlan 10,20,30

end以后查看一下

moekiwisama_st#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Fa0/5 on 802.1q trunking 1
Port Vlans allowed on trunk      
Fa0/5 10,20,30      
Port Vlans allowed and active in management domain      
Fa0/5 10,20,30      
Port Vlans in spanning tree forwarding state and not pruned      
Fa0/5 10,20,30      

进入nd交换机后台

moekiwisama_nd(config)#int f0/1选择Fa0/1接口

moekiwisama_nd(config-if)#switchport trunk encapsulation dot1q手动设置协议为dot1q

moekiwisama_nd(config-if)#switchport mode trunk将f0/1的模式换为trunk

moekiwisama_nd(config-if)#switchport trunk allowed vlan 10,20,30使 f0/1 trunk 允许 vlan 10,20,30

end以后查看一下

moekiwisama_nd#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Port Vlans allowed on trunk      
Fa0/1 10,20,30      
Port Vlans allowed and active in management domain      
Fa0/1 10,20,30      
Port Vlans in spanning tree forwarding state and not pruned      
Fa0/1 10,20,30